Ospf là gì

OSPF – Open Shortest Path First là một trong những giao thức định tuyến đường liên kết – state điển hình nổi bật. Đây là một trong giao thức được áp dụng rộng rãi trong số mạng công ty bao gồm form size lớn. Mỗi router Khi chạy giao thức sẽ gửi các tinh thần đường liên kết của chính nó mang đến tất cả các router trong vùng (area). Sau một thời gian hội đàm, các router đang đồng hóa được bảng cửa hàng dữ liệu tâm trạng con đường links (Link State Database – LSDB) cùng nhau, từng router đều phải có được bản vật dụng mạng của cả vùng. Từ kia từng router sẽ chạy lời giải Dijkstra tính toán thù ra một cây đường đi nthêm độc nhất vô nhị (Shorthử nghiệm Path Tree) và phụ thuộc cây này nhằm xây dựng nên bảng định con đường.

Bạn đang xem: Ospf là gì

1. Link State

Link State là giao thức kiến thiết đường đi tốt nhất (Shordemo path first) thông qua lời giải Dijkstra. Các router chỉ việc trao đổi ban bố của nhau qua gói tin Hello nhưng mà không bắt buộc gửi cả bảng định con đường. Sau Lúc tất cả thông tin nó sẽ xây dựng dựng ra một bảng định tuyến với đường đi rất tốt.

Chỉ số AD: là chỉ số tin cẩn của những giao thức

Cost: là cực hiếm được xem theo cách làm 10^8/Bandwidth

OSPF chạy xe trên nền IP còn RIP chạy xe trên giao thức UDP

Các gói tin IPhường. vận chuyện những gói tin OSPF thì ngôi trường Protocol- ID = 89

2. Cơ chế hoạt động vui chơi của giao thức OSPF

Router chạy theo OSPF thì nó cần trải qua 4 bước:

Router ID

Thiết lập Neighbor

Trao thay đổi LSDB (Link State Database)

Xây dựng bảng định tuyến

a. Router ID là gì ?

Router IDđơn giản là một trong quý giá cần sử dụng định danh cho Router khi sử dụng giao thức OSPF

Có định dạng của một can hệ IP A.B.C.D. Có định dạng là xúc tiến IPhường chứ đọng không phải là liên hệ IP

Lấy IP cao nhấtvào cácInterface vẫn hoạt độngvàưu tiên cổng Loopback.

+ IPhường cao nhất: là địa chỉ IPhường cao nhất. IP bao gồm octet đầu cao hơn nữa được xem như là mập hơn

Vd: 1, 192.168.1.1,

2, 192.168.1.2, => là lớn nhất (xét trường đoản cú 192, kế tiếp sang 168 tiếp nối sang 1 và ở đầu cuối là 2)

3, 172.16.255.255,

4, 10.255.255.254.

Địa chỉ 2 > 1 > 3 > 4

Vậy ID của Router sống đấy là 192.168.1.2

+ Interface active: là cổng đã (up/up) Status up cùng protocol up.

+ Cổng Loopbachồng sẽ được ưu tiên hơn vì nó không nhiều bị hỏng cùng bình ổn.

b. Thiết lập quan hệ nam nữ láng giềng

Các Router đã gửi gói tin Hello (10s/1 lần). Được dùng để đưa ra router láng giềng, chuyển một quan hệ giới tính bóng giềng thanh lịch tâm lý 2 bước (2- Way), tiếp nối Hello giúp giám sát nhẵn giếng lúc nó bị lỗi.

Lần đầu tiên gói tin Hello gửi tới tương tác 224.0.0.6

2 Router buộc phải thỏa mãn nhu cầu các điều kiện sau mới được Điện thoại tư vấn là nhẵn giềng (phải đảm bảo 5 thông tin):

=> Cùng Area-id: Khi mạng lớn bạn ta chia làm các vùng, vùng như thế nào hư thì chỉ vùng đó Chịu ảnh hưởng. Mỗi một vùng sẽ đặt cho một Area-id. Vùng trung chổ chính giữa có Area-id bắt buộc bằng 0. Mọi vùng khác buộc phải tất cả con đường truyền thẳng về vùng 0 nó mới truyền được dữ liệu.

=> Cùng Subnet: 2 ip cần cùng Subnet bắt đầu ping với hiệp thương được thông tin.

=> Phải cùng thông số: Hello/Dead-time ở bên trên 2 cổng. Mặc định Hello là 10s, Dead là 40s sau 40s nó sẻ bỏ kết nối.

=> Phải thuộc Xác thực trên 2 cổng. Dành đến mạng phệ (metro). Lúc đặt đúng đắn những router khác ko rước được thông báo.

=> Phải cùng cờ Stub Area Flag: dành riêng cho OSPF đa vùng (học vào CCNP)

Để xem được hàng xóm sử dụng lệnh: Show IPhường OSPF Neighbor

c. Trao đổi LSDB (Link State Database)

Mỗi Router mọi chưa một bảng LSDB

LSDP: Link State Database. Do nó mập nên nó chia nhỏ tuổi ra thành những phiên bản LSA để gửi

LSA: Link State Advertisement. Để gửi được LSA thì nó cần đóng gói vào bản tin LSU

LSU: là Link State Update. Để thảo luận cùng gửi được LSU thì nó có 2 loại môi trường thiên nhiên gửi:

- Point - to lớn - Point: 2 router chạy cùng nhau theo giao thức HDLC hayPPP. Sau lúc nó liên kết được hàng xóm thì chỉ có 2 Router thương lượng trực tiếp Hotline là Full

- Broadcast Multiaccess: là những Router kết nối với nhau thông sang 1 Swtich. R1, R2, R3, R4 thuộc kết nối vào 1 Switch. Lúc này nó trao đổi LSDB sẽ không giống hoàng toàn.

Trong 4 Router vẫn thai ra một Router làm DR-Desigted Router, 3 router sót lại sẽ thai ra một BDR-Backup DR.

Các Router sót lại đã là DR Other. 2 Router là DR Other sẽ không gửi thẳng cùng nhau. Nó sẽ gửi đọc tin về DR 1 phiên bản cùng 1 phiên bản đến BDR. Sau kia DR đang gửi phân phối hận xuống cho những Router sót lại.

DR Other vẫn gử công bố về DR bằng xúc tiến 224.0.0.6. DR sẽ gửi LSDB đến DR Other là 224.0.0.5.

Xem thêm: Ngành Và Chuyên Ngành Là Gì ? Ngành Học Nào Hot Hiện Nay? Ngành Và Chuyên Ngành Khác Nhau Như Thế Nào

Tiêu chí như thế nào được thai làm DR với BDR:

Trên mỗi cổng kết nối của các Router sẽ sở hữu một tsay đắm số: Priority(0-255) mặc định là một trong. Con như thế nào tối đa là DR với bé nào thấp hơn là BDR.

Câu lệnh: R(config)# int F0/1 => R(config -if)# ip ospf priority (0-255)

Nếu không may tất cả Priority là cân nhau nó đang phụ thuộc vào Router - ID. Router tất cả Router-id tối đa là DR

Nếu hệ thống sẽ gồm DR cùng BDR nếu như cắm thêm 1 Router new gồm DR cao hơn nó vẫn ưu tiên DR vẫn hoạt động.

Nếu để Priority là 0 nó sẽ không thai DR tuyệt BDR

c. Xây dựng bảng định tuyến nó cần sử dụng giải mã Dijkstra để đưa đi ra đường đi giỏi nhất

3. Cách tính Metric

Cost=10^8 /bandwidth

Băng thông nên thay đổi ra solo vị: bps

Vd:

*

4. Cấu hình

a. Wildthẻ mask

Wildthẻ masklà 1 trong những vẻ ngoài lôi ra địa chỉ IP của một dải linh thiêng hoạt. Nó là 1 trong dãy nhị phân 32 bit được dùng kèm với cùng một liên quan IP tsi mê chiếu nào kia. Bit của địa chỉ IP. tương xứng cùng với Bit 0 là cố định, bit của IPhường. tương xứng cùng với bit 1 đang thắt chặt và cố định.

Vd: 192.168.1.0/24

Ta có: IP:192.168.1.0

WCM: 0 . 0 . 0.255

Vd: 192.168.1.32/27

Ta có: IP: 192.168.1.001xxxxx

WCM: 0 . 0 . 0 .00011111 => 0.0.0.31

b. Các lệnh cấu hình

Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ gồm ý nghĩa sâu sắc nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là cùng mạng nguyên tố này rất quan lại trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

Hiệu chỉnh OSPF

Router - ID:

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IPhường chính là ID)

Sau đó trsinh sống ra mode cai quản trị:

R(config)# Clear ip ospf process thì nó mới gồm hiệu lực

Priority:

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time:

R(config-if)# ip ospf hello-interval thời gian (là giây)

R(config-if)# ip ospf dead-interval thời hạn (là giây)

Xác thực bên trên 2 router

Vào trong cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

5. Chú ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.đôi mươi, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.trăng tròn, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate

II.Single-area cùng Multi-area OSPF

1. Cấu hình Single-area OSPF

a. Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có chân thành và ý nghĩa nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là thuộc mạng yếu tắc này siêu quan tiền trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

b. Hiệu chỉnh OSPF

Router - ID

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IPhường chính là ID)

Sau đó trsinh sống ra mode quản ngại trị:

R(config)# Clear ip ospf process thì nó bắt đầu bao gồm hiệu lực

Priority

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time

R(config-if)# ip ospf hello-interval thời hạn (là giây)

R(config-if)# ip ospf dead-interval thời hạn (là giây)

c. Xác thực trên 2 router

Vào vào cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

d. Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

2. Cấu hình Multi-area OSPF

a. thông số kỹ thuật Multi-area

Router(config)#router ospf 5

Router(config-router)#redistribute ospf 10 subnet

b. Redistribute vào OSPF

RIP.. => OSPF

Router(config)#router ospf process-id

Router(config-router)#redistribute rip subnet.

EIGRP-OSPF

Router(config-router)#redistribute eigrp as-number subnet.

Static route & Default route => OSPF

Router(config-router)#redistribute static subnet.

Connected route => EIGRP

Router(config-router)#redistribute connected subnet.

Default route => OSPF

Router(config-router)#default-information originate.

Nếu họ không gửi vào tsi số metric thì mang định metric sẽ được đặt cho tuyến được redistribute vào là trăng tròn.

Xem thêm: Bệnh Bại Não Là Gì ? Nguyên Nhân, Triệu Chứng Và Cách Điều Trị

3. Chụ ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.trăng tròn, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.trăng tròn, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate


Chuyên mục: Hỏi Đáp